Webmail Login/Access
Incident Report for Enom
Resolved
This issue is resolved and our engineering team have implemented a fix and service levels have been restored.
Posted Apr 29, 2024 - 08:44 PDT
Investigating
We are encountering issues with Webmail. We are getting reports that some users are unable to login to or access webmail.

Our engineering team has been engaged and are investigating currently.
Posted Apr 29, 2024 - 05:51 PDT
This incident affected: Basic Email Service.